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Migrating from PADS to OrCAD

Overview

Choosing the right PCB design solution is never an easy task. No matter if you are a startup company looking for tools to
develop your next innovative electronic product or a large enterprise wanting a better solution to improve the productivity of
your design team, selecting a PCB solution can be a daunting task. No one wants to get 75% of the way through a design to
find out that the software you selected is not going to achieve what you need to accomplish.

Before you select a PCB design software package, there are many performance and capability aspects you should consider
first:

> Does the capabilities of the application and its technology meet your design requirements?
> Does the design software licensing fit within your budget?

> What level of support can you expect? Will you be able to get quick responses to your questions and access online tutorials?
Is local help available?

» Can the application scale with your needs? As designs are getting more and more complex, will the capabilities of the tool
adjust accordingly?

» How many other companies in your industry are using this tool and what is their feedback?

OrCAD® offers an excellent solution for individual designers, small design teams, and large enterprises. OrCAD offers
constraint-driven design, advanced auto/interactive routing, high-speed design, DFM, dynamic shape technology, and much
more, helping you deliver high-quality, first-time-right designs in the shortest timeframes. You can be confident that you will
have the right solution and technologies at an affordable price to meet all of your design challenges today and tomorrow. Here
are five of many reasons why:

» 30 years of innovation and leadership in the industry
» Affordable price and flexible purchase models

» Cutting-edge technologies

> Ecosystem empowered

> Industry’s best customer support

Cadence and OrCAD provide the only full scalable PCB design solution on the market that can seamlessly grow with your
needs. OrCAD products are backed by Cadence and their network or certified Cadence Channel Partners (CCP). Get help when
you need it by phone or email from local, knowledgeable PCB design professionals.

Like many companies selecting OrCAD, you have existing or legacy designs you need to convert or translate into OrCAD. The
good news is that OrCAD is supplied with an integrated and proven PADS translator built in. This guide will walk you through

the steps and process involved in getting your design IP into the OrCAD format so you can start realizing the advantages of

moving to OrCAD!
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Migrating from PADS to OrCAD

Import Your PADS Schematic Data to OrCAD Capture

Step 1 - Export Schematic Data from PADS

In DxDesigner export your PADS schematic to EDIF 2.0 format using the EDIF Interfaces window:

EDIF Interfaces

EDIF Schematic Writer

Schematic/Symbol m

P

Project |F \EVM_Demo\WC709\VC709.prj | Browse
Qutput | FAEVM_Demo\WVC709\vc709.eds | Browse
Configuration file | | Browse
Leve 1
Convert Design Hierarchically
[IDon't Use Library Alias
I Translate Symbol

< >

Note: If you are using PADS Logic you will need to convert your design into DxDesigner first using the Mentor-supplied
conversion utilities, then you can proceed with Step 1 of the conversion process.

Step 2 - Import Schematic Data to OrCAD Capture

Once the EDIF file is created, launch OrCAD Capture and select the “File » Import » EDIF” command from the top menu.

)} Capture - [Start Page]

File = Design Edit View Tools

New
Open

Close

Import
Export

Print Setup...

Print Area

1 chusers\..\out'\migrate.opj

‘owersim.opj

P 5l Analysis  Accessories

PSpice

Altium Schematic Translator

Eagle Schematic Translator

Import Design

Open

Select your EDIF file, your destination output folder, and make sure you select the correct configuration file. Click OK to begin
the translation. Once the EDIF file has translated into OrCAD Capture, some text cleanup may be required.
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Migrating from PADS to OrCAD

Import Your PADS PCB Design into OrCAD PCB Editor

Step 1 - Preparation

In the PADS PCB application, export your PCB database to the most recent ASCII format. The newer version of the ASCII can
be exported using PADS version 5 or later by choosing the menu items: “File » Export » ASCII”

This creates an ASCIl database (*.ASC) that will be used for translation into OrCAD Capture format. Refer to the PADS
documentation if more detail on exporting an ASCII database is required.

Note: Only copper pours in PADS defined as positive data are recognized by the translator.

Step 2 - Create a Blank Board

This step will ensure the translated PCB file is placed in the correct location. Create a new board from the home screen in the
OrCAD PCB Editor. You can also use the “File » New...” command from the top menu bar.

In the New Drawing window, navigate to the folder where you want the translated PCB to be saved. Enter a board name; this
name is just a placeholder and can be changed after the import completes.

BH Mew Drawing X

Project Directory: C.../Migrate/out

Drawing Name: Browse..

Drawing Type: Eoard Template...

Board

Board (wizard)

Module

Package symbaol
Package symbol (wizard)
Mechanical symbol
Format symbol

Shape symbol

Flash symbol

Cancel

In OrCAD PCB Editor, choose “Import » Translators » PADS” from the top menu bar:

BB PaDs IN - O ®
ﬁ OriCAD PCB Designer Professional: unnamed.brd

File Import Setup Display Qutline Add Edit Place Rout| PADS ASCI input file:

. Y & & T Options File:
:r"' Y v ) c’ /\ /\ g /+ G

Cutput Design:

isi Start Page unna
Visik vard Parameters... - & X g B Show options dialog

Techfile...
Globd  (clippoard...
Translate Viewlo
View Placement... = )
Layer Translators
Maore

Conductors

Planes Altium Schematic to DE HDL...

Masks

Eagle PCB...

Browse to the .ASC file to be translated, create an options file, and select an Output Design folder.
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Migrating from PADS to OrCAD

Step 3 - Layer Mapping to OrCAD PCB Editor

Select your ASCII database for Import, enter an options file name and select

then select “Translate”:

BH paps N

PADS ASCI input file:
Options File: Cistest.ini

Cutput Design: C:/layout.brd

Show options dialog

Translate Viewlog Close

"Show options dialog” to create your options file,

Map PADS layer numbers to the corresponding OrCAD PCB Editor layers (PCB footprint, board data layers, etch):

PADS To Allegro Translation Options

PADS to allegro layer mapping

LINE COPPER TEXT DECAL PaD  Via

Layer Layer Name Class Subclass L

0 All layers BOARD GEOMETRY  ALL

1 Primary Component Side ETCH TOP

2 Ground Plane ETCH Ground Plane

3 Power Plane ETCH Power Plane

4 Secondary Component Side  ETCH BOTTOM

5 Layer_5 UNUSED .

B Layer_B UNUSED

7 Layer_7 UNUSED

2 Layer_8 UNUSED

9 Layer_9 UNUSED

10 Layer_10 LINUSED ]
| < >

Class:  BDARD GEOMETRY v Sub Class: | v

Automatic solder layer creation

[ Create solder layers.  Mils to oversize: E

[[]Do not create Teardiops

[[] Create Dynamic Shapes
Through pin thermal/anti pad creation
[ create thermal/anti pad Thermal pad oversize: 10.000  mils
Antipad oversize: 10.000 | mils Spoke width: 10,000 mils

l Cancel

After mapping, the Command window will show the translation progress. Once the translation finishes, the translated .BRD

file will be accessible in the folder specified in the Output Design field.

Note: In some cases, especially for larger boards, it might seem like PCB Editor has stopped working. Do not close it as tests
on large boards have shown translation times taking over five minutes, although this is unusual.
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Migrating from PADS to OrCAD

Note: Make sure to check the log file after the translation completes. The log file will contain all the text shown in the
Command window once the translation completes; this file can be found in the root folder as the translated .BRD file.

The translated PCB layout will appear in the main editor window inside the new drawing that was created in Step 2. Save the
.BRD file before continuing.

m OrCAD PCB Designer Professional: unnamed.brd

File Import  Setup Display  Outline Add Edit  Place Route Shape Check z Tools Manufacture Export  Help

RERLBTO C A4 AMB S#iSEMIOORQARAQQT ™

Visibility - B X Start Page unnamed

Global visibility On
View

Layer Stackup | PRIMARY

)

Conductors
Planes
M4 wasks
Dielectrics

SIS NS
NERAS
SIS

All Layers

N
XN

Too Solder

B Enable layer select mode

Find
Design Object Find Filter
All Off
Bond wires

[N N4

Step 4 - Checking the Imported Database for Design Errors

Check the database for errors using the command “Check » Database Check":

B DBDoctor (Database healt.,  — >

Update all DRC {including Batch) Check

Check shape outlines

) Close
B Regenerate Xnets

; Viewlog...
Performance advisor...

Help

The DBDoctor will flag any errors or remaining DRC errors that should be addressed during cleanup.
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Migrating from PADS to OrCAD

Synchronize the Schematic to the Migrated PCB

Step 1 - Creating a Netlist in OrCAD Capture
From OrCAD Capture, open the .0P3J file with the translated schematics.

Select “Tools » Create Netlist”.

Create Metlist
EDIF200 IMF PSpice SPICE VWerilog VHDL Other

PCB Footprint
[ ned property string:

PCB Footprint

e PCB Editor Netlist Setup ...

C:AlUsershallegro

iles Directory:

Output

Cancel

Click “OK" to create the netlist and accept saving the project and creating an allegro subdirectory.

OrCAD Capture

2 QUESTIOM(OR
g specified as Metlist direc

Note: The allegro subdirectory with the netlist is created in the directory where the OrCAD Capture design is located. This
directory name will be included by default. If you change this target directory, you will need to make sure you point to this
new directory when you import the netlist in Step 2.

Note: Duplicate pin names (other than PWR or GND designated pins) must be resolved. Logic symbols and PCB footprint pin
mismatches may need to be corrected. (This occurs when unused pins on the logic symbols are not accounted for with
no-connect property.)

Once the schematic has been synchronized to the translated PCB, cross-probing and cross-placement tools can be utilized.
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Migrating from PADS to OrCAD

Step 2 - Importing the Netlist in OrCAD PCB Editor

Select “Import » Netlist”.

B Import Logic/Metlist - *

Cadence | Other
Branding: Mone Import
Import logic type Place changed component
@ Design Entry HDL/System Capture QO Always
m OrCAD PCB Designer Professional: unnamed.brd O Design Ent apture) @ Never
File Import Setup D iy Qutline Add Edit Place Route Shape

13 DG AR AT

D

oK

mbol

Cancel
HD! straint Manager Enabled Flow options
Visik I 4 Start Page unnamed

lor/Board Parameters... - Q Import changes only @ Overwrite current constraints

Techfile... B Show constraint difference report
Globa
W Allow etch removal during ECO
M Ignore FIXED property
_reate user-defined properties
te L from input data

View Placement...

Translators »

re »

A A A&
All Layers

Top | N |
Bottom HE

O Import directory:

In the Import Logic window, make sure that the Import directory points to the allegro subdirectory with the netlist. This
directory was created in the previous step.

Note: If you used a different directory name in Step 1, then make sure you navigate to that directory in the Import Logic
window.

Click “Import” to import the netlist.

Step 3 - Check Design Status

Select “Check » Design Status” and, if necessary, click “Update to Smooth” to update the dynamic copper shapes.

Status - x
&

Symbols and nets

Unplaced s
Unrouted net:
Unrouted connections:
Shapes
Isolated shapes:
Unassigned shapes:
Out of date shapes:
Dynamic fill: O smooth @ Fast @ Disabled Update All

and Backdrills

DRC errors: Up To Date Update DRC
Shorting errors:
>HOTS S On-line DRC
Waived DRC errors: On-line DFM checks
Waived shorting errors:
Out of date backdrills
Statistics

Last saved by:

Editing time: 10 minutes

Refresh
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Migrating from PADS to OrCAD

Step 4 - Check Physical and Spacing DRC Constraints

From OrCAD Capture, start the Constraint Manager from the “PCB » Constraint Manager” menu item. Check and verify the
physical and spacing DRC rules.

Update the online DRC using the toolbaricon.

Step 5 - Change to Preferred Colors

Changing the colors to suit your preferences is easy. Select the color and visibility toolbar icon and change your color prefer-
ences accordingly.

Importing Your PADS PCB Libraries into OrCAD PCB Editor

Invoke the library translator from within OrCAD PCB Editor using the “Import » Translators » PADS Library..” command
from the top menu.

ﬁ OrCAD PCB Designer Professional: unnamed.brd
File Import Setup Display Qutline Add Edit Place Route Shape Check

_F+ Netlist... X ) C' )f' /\? /+ @ [fl *#

MCAD
Visik 5 OX Start Page unnamed

Color/Board Parameters... -
Techfile...

Globd  rjippoard...
View Placement...
Layer Translators
Mare

Layer A PADS Library...
Conductors

Planes
Masks
Dielectrics

Altium PCE...
Altium Schematic to DE HDL..,
Eagle PCE...

All Layers

Too Solder /|
M Enable layer select mode

Use the OrCAD library translator to browse to the folder where your PADS package and decal libraries are located, and specify
your desired output folder for the migration. Type in the file name for the options file you wish to create, select the “Show
Options Dialog”, and then “Translate™:

Bl PADS LIBRARY TRANSLATOR - O x
PADS Library Directony: penPADSLibraries-master
Options File: C:/options.ini

Cutput Directory: C:/PADSLIBS

Show options dialog

Translate Viewlog Close
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Select the options below:

PADS Layout Library te Allegro Translator Optiens

PADS to Allegro layer mapping
COPPER DECAL pap

Layer Clazs Subclaszs

1 PACKAGE GEQOMET... SILKSCREEN_TOP

1 PACKAGE GEOMET... SILKSCREEN_TOP

20 UNUSED .

27 UMNUSED

Class: ~ Sub Class: o
Create package symbaol files Create drawing files far custom padstacks
Create mechanical symbol filez Create device files

— o o —

Automatic solder/paste layer creation

[] Create solder/paste lapers  Solder oversize; 0.050  mils  Paste aversize: 0.000  mils

Through pin thermal/anti pad creation

[ ereate thermal/anti pad Thermal pad oversize:  0.250  mil
Antipad oversize: 0260 mils Spoke width: 0350 mis
Cancel

The OrCAD PCB Editor library footprints and padstacks will be available in the specified folder as .DRA files.

Next Steps

Now that you know how easy it is to move to OrCAD PCB Designer, are you ready to learn more about the exciting OrCAD
features and technologies which will help you improve your design productivity? Here are some resources you can leverage
to learn more about OrCAD technologies.

What's New in OrCAD

Want to know what are the new features in the latest OrCAD release? Check out what's new.

Customer Testimonials

See how companies leverage OrCAD to bring their products to market on time and budget. Read OrCAD customer stories.

Product Information
Need more videos, application notes, or datasheets to dive deeper into the OrCAD technologies? View OrCAD product pages.

If you have any questions about migration or OrCAD, please do not hesitate to contact your local Cadence Channel Partner at
http://orcad.com/about/contact-us.

Cadence is a pivotal leader in electronic design and computational expertise, using their Intelligent
System Design Strategy to turn design concepts into reality. Cadence customers are the world’s
- ® most creative and innovative companies, delivering extraordinary electronic products from
C a d e n c e chips to boards to systems in the most dynamic market applications. www.cadence.com



https://www.orcad.com/products/customize-pcb-design-experience
https://resources.pcb.cadence.com/customer-success-stories
https://www.orcad.com/orcad-solutions
http://orcad.com/about/contact-us
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